Excel - Capitulo 4

Excel - Capitulo 4

FUNCIÓN SI ANIDADA

Aprende a trabajar con la función condicional SI, es muy usada en todos los campos de acción y sirve para tomar decisiones (verdadero y Falso) que fueron programadas en el momento de crear la función. En este caso la trabajaremos anidada, esto quiere decir que emplearemos una función dentro de otra para así trabajar con más de 2 decisiones.

En este ejemplo vemos hasta una anidada de 4 niveles, sin embargo excel permite un anidado de hasta 64 funciones, aunque sera muy improbable llegar si al caso a la mitad de dicho limite.

La función SI ANIDADA, es un poco mas compleja pero con un poco de atención ¡podrán comprenderla muy bien!, solo es repetir y repetir la función así que nada de nervios 😀


DESCARGAR MATERIAL DE APOYO
Descarga el archivo que vemos en el vídeo desde los siguientes enlaces

Descargar desde Mega Descargar desde MediaFire

Descarga Directa

Mega | MediaFire | Descarga Directa

Capitulo Anterior Lista de Capitulos Capitulo Siguiente


69 Comentarios

  1. Buenas, en primer lugar gracias por los tutoriales , intente recrear el ejercicio y a primeras no tuve problemas , tambien logre que el Excel identificara como error cuando el promedio es negativo en lugar de mostrarlo como reprobado , quedo asi:
    «=SI(F3<0;"ERROR";SI(F3<=3,9;"RECURSA";SI(F3<6;"APRUEBA";SI(F3<9,9;"PROMOCIONA";SI(F3=10;"MEDALLA";"ERROR")))))" (sistema de notas del 1 al 10)
    Sin embargo tuve un problema al querer agregar una variante, me propuse que el Excel detectara cuando hay un error en las notas que conforman el promedio ademas del mismo, por ejemplo si las notas son 6 , 5 y 4 el promedio sera 5, pero existira un error en las notas subidas .no logro hacer una formula funcione , me quedo asi "=SI(C3:E310;»ERROR»;SI(F3<0;"ERROR";SI(F3<=3,9;"RECURSA";SI(F3<6;"APRUEBA";SI(F3<9,9;"PROMOCIONA";SI(F3=10;"MEDALLA";"ERROR")))))))" (entre muchas variantes) pero solo logro que salga "#¡VALOR!" en la celda

    1. Hola Emilio!
      No le entendi muy bien que desea lograr en el segundo punto, sin embargo debe tener en cuenta que la función SI trabaja a través de condiciones o «preguntas», dicho esto la primera condición «SI(C3:E310;”ERROR”…» no es como tal una pregunta ya que solo le estas dando un rango. También recuerda que la pregunta NO debe tener rangos, debe tener una celda y un conector como tal (mayor, menor, igual, etc…)
      Saludos!

    2. buenos dias como estan lo que pasa es que estoy haciendo este ejercicio paso a paso pero el ejemplo no termine de comprender como hacer para que salga el ultimo resultado como hacer gracias

    3. es un punto muy valido y seria muy inteligente poderdetectar un error en las calificacions que comprenden el promedio tambien… pero en vez de hacer una formula tan larga y dificil de reparar si por er`ror cambias algo es mejor utilizar la validacion de datos para eso

  2. Buenas noches. Por más que intento hacerlo, me da el error de ¿nombre?. Busco a ver si tengo algún error en alguna palabra y según yo, está todo correcto. Por qué será?

  3. dostin buena noche, me puedes colaborar please:

    tengo 7 marcas diferentes y me dice el ejercicio que si compran tres de estas marcas les de descuento a estas tres o de lo contrario no le de descuento… Caramba pero no lo logró realizar , te dejo la formula que hice jejeje te recomiendo. =SI(Y(C26=»valler»;C26=»totto»);(«descuente»);(«no descuente»))

    Gracias

    1. Hola Laura. Estuve aprendiendo con los videos y por lo que ví me parece que tu fórmula está mal porque abriste paréntesis en el «descuente», fijate si así te funciona =SI(Y(C26=”valler”;C26=”totto”);“descuente”;“no descuente”)

  4. Hola dostin, desde Chile, felicitaciones por lo que haces amigo, me gusta mucho aprender, pero personas como tú o bien tu equipo son las que hacen falta en este mundo donde el conocimiento se atrinchera y no es compartido, creo que cuando se hace lo correcto debe ser siempre un hecho reconocer públicamente estos gestos de buena voluntad, te dedico una frase de Einstein, «Debes hacer sencillo lo complejo, que incluso un niño o tu abuela puedan entenderlo, pero aún así no te excedas en aquello», estos trabajos son de esa forma, yo también soy profesional de el área de las ciencias tecnológicas, y una forma pedagógica más asertiva es pensar que le enseñas a un niño, te agradezco sigo este curso de Excel, y espero que te vaya excelente….

  5. Sus vídeos son muy útiles, los explica de una manera tan sencilla que todo se ve muy fácil y estoy aprendiendo mucho. Gracias por compartir sus conocimientos.

  6. Genial estoy contenta logré hacer el ejercicio ingresando un número negativo y me desplega la palabra error.

  7. buenas tardes, muy buenos tus vídeos gracias, mi pregunta es, intente hacer lo de capitulo 4 y en mi excel me dice que son demasiados argumentos que debo hacer en ese caso?

  8. Quise realizar la tarea que dejas en tu pagina sin embargo, intente ya en varias ocasiones pero no lo logro me podrías ayudar ?

  9. COMO SE HARIA LA FINCION ANIDADA SI QUIERO HACER UNA SUMA O MULTIPLICACION PONIENDO COMO EJEMPLO LA TIENDA DEL OTRO CAPITULO

  10. Dostin muchas gracias por sus tutoriales y por el concepto «el conocimiento es para todos». Practicando con la función Si, Anidada encontré una dificultad en una sola linea y es que me arroja como resultado numeral, interrogación NOMBRE?, Esto aunque todas las demás lineas arrojaron resultados correctos. Cual pudiera ser mi error?

    1. =SI(F4<0,"ERROR",SI(F4<7,"DEFICIENTE",SI(F4<8,"INSUFICIENTE",SI(F4<9,"ACEPTABLE",SI(F4<10,"SOBRESALIENTE",SI(F4=10,"EXCELENTE"))))))
      ESTA ES LA REPUESTA 🙂

  11. Hola Dostin, tengo un problema cuando quiero poner «=», por ejemplo en condiciones al querer escribir «=5» y precionar enter, se me borra automaticamente el «=» quedando solo el n°5. Yo creo que por eso no puedo obtener un buen resultado con la formula, me salta error y que cambie la formula entre otras cosas.. por ejemplo me dice que en la formula adelante de =5 lo escriba asi «‘=5», al escribirlo asi, como me aconseja excel me sigue saliendo error.

  12. BUENOS DÍAS, MIRA CUANDO UNO ESTA HACIENDO LA FORMULA AL ESTAR HACIENDO LA FUNCIÓN DE «SI F5=5» NO LO DEJA HACER EXCEL POR QUE AL DAR IGUAL = EXCEL PIENSA QUE VAS A DAR OTRA FORMULA Y NO DEJA CERRAR LOS PARACENTESIS PARA ARROJAR EL RESULTADO DESEADO .

  13. Hola Dostin, muchas gracias por tus tutoriales he aprendido mucho, hice el ejercicio pero en el excel si tengo por ejemplo un «3» como nota me lo pone como bueno, y la condición es que si es menor que 3 entonces «Aceptable» en este caso intenté con hacerlo «<=" pero no me dio. Alguna sugerencia?

  14. Que tal Dostin me preguntaba como es que colocaste el «=5» en la casilla L10 sin que el programa lo tome como una operación, gracias por tu contenido 🙂

  15. Hola, intente hacerla «tarea» pero realmente no supe como hacerla, por mas que intentaba con diferentes opciones no me daba. Alguien podría colaborarme por favor. Les agradezco de antemano

  16. Buenas tardes Dostin!!!

    Excelentes tutoriales, Muchas gracias, Por favor ayudame en algo; cuando estoy en el si anadido, uando voy a colocar SI(D4=5″EXCELENTE» este punto no me deja dice que hay error y debo colocar un apostrofe ya que todas las formulas inician con un =, entonces no he podido terminar esa funcion por es punto, intente colocar el apostrofe pero no pude.

    Espero pronto respuesta, gracias.

    1. Espero estar en lo correcto, pero te esta haciendo falta realizar la formula correctamente, chequea esto:
      =SI(D4=5;″EXCELENTE”; y luego se continua con el resto.

  17. Por qué será que no tira el mismo resultado cuando haces la formula en forma descendente, por ejemplo =SI(F16=5;»excelente»;SI(F16<5;"Sobresaliente";SI(F16<4;"aceptable";SI(F16<3;"insuficiente";SI(F16<2;"Deficiente";"error"))))) ……………, solo te tira el resultado como lo hiciste en el video,
    =SI(F6<2;"DEFICIENTE";SI(F6<3;"INSUFICIENTE";SI(F6<4;"ACEPTABLE";SI(F6<5;"SOBRESALIENTE";SI(F6=5;"EXCELENTE";"ERROR")))))

    intente hacer otros ejercicios y no me salían, pero encontre este error, en realidad no sé si es error. GRACIAS

  18. Por qué será que no tira el mismo resultado cuando haces la formula en forma descendente, por ejemplo =SI(F16=5;”excelente”;SI(F16<5;"Sobresaliente";SI(F16<4;"aceptable";SI(F16<3;"insuficiente";SI(F16<2;"Deficiente";"error"))))) ……………, solo te tira el resultado como lo hiciste en el video,
    =SI(F6<2;"DEFICIENTE";SI(F6<3;"INSUFICIENTE";SI(F6<4;"ACEPTABLE";SI(F6<5;"SOBRESALIENTE";SI(F6=5;"EXCELENTE";"ERROR")))))

    intente hacer otros ejercicios y no me salían, pero encontre este error, en realidad no sé si es error. GRACIAS

  19. Estimado muchas gracias por tus lecciones. Me sirven de mucho.
    Por favor con respecto a la tarea no me sale. Podrías indicarme cual seria la formula correcta.

  20. GRACIAS DOSTIN POR OTORGAR ESTE MATERIAL Y TENER LA PACIENCIA PARA PODER EXPLICAR TODO DE LA MANERA MAS SIMPLE.

    TENGO UNA DUDA, QUE FUNCION PUEDO OCUPAR Y COMO OCUPAR DICHA FUNCION EN CASO DE QUE EXISTA, PARA PODER PONER UNA CONDICION DE CAMBIO DE COLOR DE UNA CELDA Y ESTA VALLA CAMBIANDO, SI EL TEXTO CAMBIA.

    DE ANTE MANO MUCHAS GRACIAS, Y ESTARÉ ATENTO A TU RESPUESTA.

  21. Muchas gracias amigo, la función SI anidada me ayudo mucho en realizar una formula en donde tenia 64 condiciones y por lo tanto 64 respuestas , es una formula en la cual tengo que sacar un gasto de gas de un pozos petrolero donde tengo 3 variantes Presión de Cabeza, Presión de linea y Estrangulador (el estrangulador tiene 64 combinaciones o números de estranguladores y estos a su vez tienen un coeficiente) un poco compleja y larga la formula pero gracias por tu apoyo salio muy bien.

    Gracias y saludos desde San Fernando, Tamaulipas, México

  22. HOLA Dustin .hice todo lo que enseñas en este tutorial pero cuando cambio . la nota de excel no cambia en la nota final no se que puedo estar haciendo mal .me podrias ayudar por fa

  23. Hola Amigo. He aprendido mucho con los videos. Tengo una consulta: Donde podria conseguir ejercicios para practicar tus clases? Muchas Gracias

  24. hola Dostin muchas gracias por tus videos he aprendido mucho
    Pero tengo una duda hice la tarea pero aun asi no entiendo porque se coloca <0
    espero tu respuesta muchas gracias
    o a cualquier compañero que me pueda ayudar con esta duda

  25. Hola amigo, he revisado bien lo que dejaste de tarea, logro que cuando el resultado es mayo a 5 me de «error», pero cuando es negativo no lo logro me podrias decir que esta mal ? : =SI(F6<2;"deficiente";SI(F6<3;"insuficiente";SI(F6<4;"aceptable";SI(F6<5;"sobresaliente";SI(F6=5;"excelente";SI(F65;»ERROR»))))))) Gracias.

  26. Cómo pongo el =5, esq no me sale como ud lo tiene. Me lo Iguala, y no quiero eso.

  27. Hola Dostin con tus videos he aprendido ; pero estoy elaborando una tabla de excel, donde debo trabajar con fecha para que me sume un dia ; pero se trabaja solo de lunes a Sabado y la verdad le he hechado cabeza y no logro nelaborarla .como puedo enviartela para que me indiques como puedo deesarrollarla.como te subo el archivo para que porfis me cuentes .
    Un abracito y Bendiciones .

  28. Hola Dostin.
    En 1er agradecerte por esta gentileza de compartir tus conocimientos con el mundo, ME HA SERVIDO DE MUCHO.
    ya he visto el capitulo de la función Si ANIDADA; sin embargo cuando lo hago no me sale como a ti, la he cambiado muchas veces y solo me sale con (=5, EXCELENTE), no sé que pasa. Me puedes apoyar??.

  29. Hola Dostin, buenas noches,primero que todo quiero agradecerte por esa paciencia y carisma que reflejas en todos los tutoriales, que me han sido de mucha ayuda, tengo una duda como puedo descargar el material de apoyo para practicar, he mirado opciones y no meda, gracias..

  30. muy buenas tardes Dostin.

    Quiero agradecerte mucho por esta tu pagina que me esta ayudando mucho a refrescar la memoria con todos los programas office.

    Quiero en la funcion «si» usar colores.
    Por ejemplo: si la cantidad fuese superior a 1000 el cuadro queda rojo. si fuese superior a 2000 queda verde.

    Sé que es posible porque ya lo hice an algun momento pero no me acuerdo.
    Por eso que me estas ayudando tanto y lo agradezco mucho

  31. buenas noches dostin, me gustaría saber como hacer para que no desaparezca el igual en en el cuadro de las condiciones. gracias

  32. Hola, me encantaria recibir retroalimentación de la tarea asignada en el video, de usar error cuando el resultado del promedio fuera negativo, lo estuve intentando y no fue posible. De esa manera aprendemos más. Muchas gracias.

  33. Hola Dustin. Muy bueno el curso. Pero tengo un problema que no logro resolver. he hecho paso a paso las indicaciones y no lo resuelvo.todo queda perfecto en la celda que uso SI anidada. pero cuando desplazo a las celdas de abajo, se repite la misma calificación, sin importarle el promedio. Eso me sucedió cuando había copiado un cuadro y lo pegué abajo. Entonces, probé en otra hoja nueva, nuevamente un problema: la primera celda perfecta cuando cambio los valores o calificaciones, la nota final cambia correctamente, pero cuando desplazo hacia abajo a las otras celdas, la nota final sólo acepta dos respuestas, no todas las opciones. Me puedes escribir a mi correo y te envío capturas. Y muchas gracias.

  34. Una acotación: el error también se presenta en la celda que aplico la SI anidada. Sólo reconoce el valor = y el valor máximo de <, es decir Excelente y Sobresaliente. Como en el país que estudié la máxima nota es 20. Coloqué =20 excelente y <20 sobresaliente… luego <19 distinguido, <16 Regular, <14 insuficiente, <10 deficiente, y el error, claro, todo con sus comillas, en mayúsculas, y todo como debe ser. Pero pareciera que Excel reconoce el =20 como Excelente y todo lo que sea menos de 20 lo califica como sobresaliente…. y el resto de respuesta no las aplica.

  35. Pues ya lo resolví. Resulta que yo estaba colocando las respuestas de mayor a menor y el programa como que entraba en conflicto… no sé, y sólo reconocía el valor verdadero y el valor falso, no lo anidado en ello. Pero lo hice tal y como Dostin lo tiene acá…. ingresar las respuestas de menor a menor y así sí funcionó. Es una pena que no se pueda anexar capturas en el comentario para visualizar lo que expreso. Bueno, seguimos, próxima clase.

  36. «….. ingresar las respuestas DE MENOR A MAYOR y así sí funcionó.» Fue lo que quise expresar.

  37. =SI(F2<2;"deficiente";SI(F2<3;"regular";SI(F2=3;"bien";SI(F2<0;"mal";"error")))), hola, quise hacer el ejercicio del 3 y puse que si es menor de cero metiene que decir mal, sin embargo me dice deficiente, lo cambie por 1 y me dice lo mismo, quise poner menor de 1 y que saliera mal y me sale deficiente, gracias por hacernos mejor personas!!!!!!

    1. Vamos a hacer un ejercicio lógico. ¡Es fácil!
      Digamos que escriben «-5» (menos cinco). Ese número es menor a 0, en teoría debería decir «mal». Sin embargo, si miramos su función, tienes como primera condición «Si es menor a 2, colocar Deficiente». Y -5 es menor a 2, entonces el sistema dice Deficiente y finaliza la función. 😊
      Esa como tal es la explicación. Espero haberme hecho entender.
      ¡Saludos!

  38. Hey que tal, antes que todo debo felicitar la manera en como explicas todo esto eres fenomenal, bueno, estoy teniendo problemas con este capitulo debido a que elaboro exactamente la formula como la haces y me da error pero de los comentarios escoji la formula de otra persona que la comento en youtube exactamente igual y no da error y a mi si me esta dando error, e veridicado si mi excel trabaja con ; y si trabaja con punto y coma, aqui te dejare mi formula que es la que me esta dando error y cuando pongo la del comentario que te explique que le hago copy paste me sale muy bien y la mia no y entiendo que la formula esta identica, espero que me puedas ayudar a continuacion te dejo la muestra que estoy poniendo =SI(F6<2;''DEFICIENTE'';SI(F6<3;''INSUFICIENTE'';SI(F6<4;''ACEPTABLE'';SI(F6<5;''SOBRESALIENTE'';SI(F6=5;''EXCELENTE'';''ERROR'')))))

    1. ¡Hola Angel!
      El problema según veo, está en el uso de las comillas, estas colocando doble comilla simple y NO la comilla doble. Por favor rectifica. 😊
      Saludos!

  39. hola muy buenas tardes gracias por compartir tu conocimiento en este periodo de cuarentena me esta ayudando mucho, en cuestión a la tarea que colocas de que diga error en vez de deficiente, la respuesta seria entonces modificar en la formula el <2?

  40. Muchas gracias por el vídeo.
    Realice la actividad sin ningún problema, también hice la tarea y no tuve ningún inconveniente me puso a pensar mucho por un momento, sobre todo me ayudo mucho tu gran explicación.
    Nuevamente gracias por compartir tu conocimiento.
    ¡Bonita tarde!

  41. MIRA ME DICE QUE TENGO QUE COLOCAR UN APOSTROFO, PERO TU NO DICES QUE HAY QUE COLOCAR ESO. NO ENTIENDO. GRACIAS POR LA RESPUESTA.

  42. Hola, disculpa que me meta, se que quizas esperes respuesta de Dostin pero te quise responder porque a mi me daba ese error similar y pues no se si ya lo resolviste o es el mismo caso, dar mi ejemplo quizas te ayude o si no me da igual 😉

    En mi caso este computador que estoy usando esta en ingles y el SI que va al comienzo despues del signo igual tiene que ir asi IF porque esta en ingles, tambien mi excel no tomo el signo (;) si no que tomo la (,) como dijo Dostin al comienzo del video.

    Espero puedas entender mi explicacion. Dios les bendiga.

  43. HASTA AHORA ESTE ES EL CAPITULO QUE MAS SE ME COMPLICO ,PERO FUE POR QUE TENIA UN ERROR EN MI FORMULA CLARO QUE CON UN POCO MAS DE ATENCION LOGRE CREAR MI FUNCIÓN ANIDADA CON ÉXITO TODO ES ENSAYAR ENSAYAR CON PACIENCIA …GRACIAS VAMOS POR EL 5

  44. buenas tardes una pregunta Dostin apenas estoy viendo sus tutoriales lo cual he aprendodo mucho quiisiera me aque de una duda que no he podidio resolverla con respecto al tutorial 4 donde nos dejas una actividad con repecto a la notas
    dice si una pone -100 en nota final debe salirme ERROR pero no he podido realizarla. como quedaria.

Deje una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *