Excel - Capitulo 4

Excel - Capitulo 4

FUNCIÓN SI ANIDADA

Aprende a trabajar con la función condicional SI, es muy usada en todos los campos de acción y sirve para tomar decisiones (verdadero y Falso) que fueron programadas en el momento de crear la función. En este caso la trabajaremos anidada, esto quiere decir que emplearemos una función dentro de otra para así trabajar con más de 2 decisiones.

En este ejemplo vemos hasta una anidada de 4 niveles, sin embargo excel permite un anidado de hasta 64 funciones, aunque sera muy improbable llegar si al caso a la mitad de dicho limite.

La función SI ANIDADA, es un poco mas compleja pero con un poco de atención ¡podrán comprenderla muy bien!, solo es repetir y repetir la función así que nada de nervios 😀


DESCARGAR MATERIAL DE APOYO
Descarga el archivo que vemos en el vídeo desde los siguientes enlaces

Descargar desde Mega Descargar desde MediaFire

Descarga Directa

Mega | MediaFire | Descarga Directa

Capitulo Anterior Lista de Capitulos Capitulo Siguiente


33 Comentarios

  1. Buenas, en primer lugar gracias por los tutoriales , intente recrear el ejercicio y a primeras no tuve problemas , tambien logre que el Excel identificara como error cuando el promedio es negativo en lugar de mostrarlo como reprobado , quedo asi:
    “=SI(F3<0;"ERROR";SI(F3<=3,9;"RECURSA";SI(F3<6;"APRUEBA";SI(F3<9,9;"PROMOCIONA";SI(F3=10;"MEDALLA";"ERROR")))))" (sistema de notas del 1 al 10)
    Sin embargo tuve un problema al querer agregar una variante, me propuse que el Excel detectara cuando hay un error en las notas que conforman el promedio ademas del mismo, por ejemplo si las notas son 6 , 5 y 4 el promedio sera 5, pero existira un error en las notas subidas .no logro hacer una formula funcione , me quedo asi "=SI(C3:E310;”ERROR”;SI(F3<0;"ERROR";SI(F3<=3,9;"RECURSA";SI(F3<6;"APRUEBA";SI(F3<9,9;"PROMOCIONA";SI(F3=10;"MEDALLA";"ERROR")))))))" (entre muchas variantes) pero solo logro que salga "#¡VALOR!" en la celda

    1. Hola Emilio!
      No le entendi muy bien que desea lograr en el segundo punto, sin embargo debe tener en cuenta que la función SI trabaja a través de condiciones o “preguntas”, dicho esto la primera condición “SI(C3:E310;”ERROR”…” no es como tal una pregunta ya que solo le estas dando un rango. También recuerda que la pregunta NO debe tener rangos, debe tener una celda y un conector como tal (mayor, menor, igual, etc…)
      Saludos!

    2. buenos dias como estan lo que pasa es que estoy haciendo este ejercicio paso a paso pero el ejemplo no termine de comprender como hacer para que salga el ultimo resultado como hacer gracias

  2. Buenas noches. Por más que intento hacerlo, me da el error de ¿nombre?. Busco a ver si tengo algún error en alguna palabra y según yo, está todo correcto. Por qué será?

  3. dostin buena noche, me puedes colaborar please:

    tengo 7 marcas diferentes y me dice el ejercicio que si compran tres de estas marcas les de descuento a estas tres o de lo contrario no le de descuento… Caramba pero no lo logró realizar , te dejo la formula que hice jejeje te recomiendo. =SI(Y(C26=”valler”;C26=”totto”);(“descuente”);(“no descuente”))

    Gracias

    1. Hola Laura. Estuve aprendiendo con los videos y por lo que ví me parece que tu fórmula está mal porque abriste paréntesis en el “descuente”, fijate si así te funciona =SI(Y(C26=”valler”;C26=”totto”);“descuente”;“no descuente”)

  4. Hola dostin, desde Chile, felicitaciones por lo que haces amigo, me gusta mucho aprender, pero personas como tú o bien tu equipo son las que hacen falta en este mundo donde el conocimiento se atrinchera y no es compartido, creo que cuando se hace lo correcto debe ser siempre un hecho reconocer públicamente estos gestos de buena voluntad, te dedico una frase de Einstein, “Debes hacer sencillo lo complejo, que incluso un niño o tu abuela puedan entenderlo, pero aún así no te excedas en aquello”, estos trabajos son de esa forma, yo también soy profesional de el área de las ciencias tecnológicas, y una forma pedagógica más asertiva es pensar que le enseñas a un niño, te agradezco sigo este curso de Excel, y espero que te vaya excelente….

  5. Sus vídeos son muy útiles, los explica de una manera tan sencilla que todo se ve muy fácil y estoy aprendiendo mucho. Gracias por compartir sus conocimientos.

  6. Genial estoy contenta logré hacer el ejercicio ingresando un número negativo y me desplega la palabra error.

  7. buenas tardes, muy buenos tus vídeos gracias, mi pregunta es, intente hacer lo de capitulo 4 y en mi excel me dice que son demasiados argumentos que debo hacer en ese caso?

  8. Quise realizar la tarea que dejas en tu pagina sin embargo, intente ya en varias ocasiones pero no lo logro me podrías ayudar ?

  9. COMO SE HARIA LA FINCION ANIDADA SI QUIERO HACER UNA SUMA O MULTIPLICACION PONIENDO COMO EJEMPLO LA TIENDA DEL OTRO CAPITULO

  10. Dostin muchas gracias por sus tutoriales y por el concepto “el conocimiento es para todos”. Practicando con la función Si, Anidada encontré una dificultad en una sola linea y es que me arroja como resultado numeral, interrogación NOMBRE?, Esto aunque todas las demás lineas arrojaron resultados correctos. Cual pudiera ser mi error?

    1. =SI(F4<0,"ERROR",SI(F4<7,"DEFICIENTE",SI(F4<8,"INSUFICIENTE",SI(F4<9,"ACEPTABLE",SI(F4<10,"SOBRESALIENTE",SI(F4=10,"EXCELENTE"))))))
      ESTA ES LA REPUESTA 🙂

  11. Hola Dostin, tengo un problema cuando quiero poner “=”, por ejemplo en condiciones al querer escribir “=5” y precionar enter, se me borra automaticamente el “=” quedando solo el n°5. Yo creo que por eso no puedo obtener un buen resultado con la formula, me salta error y que cambie la formula entre otras cosas.. por ejemplo me dice que en la formula adelante de =5 lo escriba asi “‘=5”, al escribirlo asi, como me aconseja excel me sigue saliendo error.

  12. BUENOS DÍAS, MIRA CUANDO UNO ESTA HACIENDO LA FORMULA AL ESTAR HACIENDO LA FUNCIÓN DE “SI F5=5” NO LO DEJA HACER EXCEL POR QUE AL DAR IGUAL = EXCEL PIENSA QUE VAS A DAR OTRA FORMULA Y NO DEJA CERRAR LOS PARACENTESIS PARA ARROJAR EL RESULTADO DESEADO .

  13. Hola Dostin, muchas gracias por tus tutoriales he aprendido mucho, hice el ejercicio pero en el excel si tengo por ejemplo un “3” como nota me lo pone como bueno, y la condición es que si es menor que 3 entonces “Aceptable” en este caso intenté con hacerlo “<=" pero no me dio. Alguna sugerencia?

  14. Que tal Dostin me preguntaba como es que colocaste el “=5” en la casilla L10 sin que el programa lo tome como una operación, gracias por tu contenido 🙂

  15. Hola, intente hacerla “tarea” pero realmente no supe como hacerla, por mas que intentaba con diferentes opciones no me daba. Alguien podría colaborarme por favor. Les agradezco de antemano

  16. Buenas tardes Dostin!!!

    Excelentes tutoriales, Muchas gracias, Por favor ayudame en algo; cuando estoy en el si anadido, uando voy a colocar SI(D4=5″EXCELENTE” este punto no me deja dice que hay error y debo colocar un apostrofe ya que todas las formulas inician con un =, entonces no he podido terminar esa funcion por es punto, intente colocar el apostrofe pero no pude.

    Espero pronto respuesta, gracias.

    1. Espero estar en lo correcto, pero te esta haciendo falta realizar la formula correctamente, chequea esto:
      =SI(D4=5;″EXCELENTE”; y luego se continua con el resto.

  17. Por qué será que no tira el mismo resultado cuando haces la formula en forma descendente, por ejemplo =SI(F16=5;”excelente”;SI(F16<5;"Sobresaliente";SI(F16<4;"aceptable";SI(F16<3;"insuficiente";SI(F16<2;"Deficiente";"error"))))) ……………, solo te tira el resultado como lo hiciste en el video,
    =SI(F6<2;"DEFICIENTE";SI(F6<3;"INSUFICIENTE";SI(F6<4;"ACEPTABLE";SI(F6<5;"SOBRESALIENTE";SI(F6=5;"EXCELENTE";"ERROR")))))

    intente hacer otros ejercicios y no me salían, pero encontre este error, en realidad no sé si es error. GRACIAS

  18. Por qué será que no tira el mismo resultado cuando haces la formula en forma descendente, por ejemplo =SI(F16=5;”excelente”;SI(F16<5;"Sobresaliente";SI(F16<4;"aceptable";SI(F16<3;"insuficiente";SI(F16<2;"Deficiente";"error"))))) ……………, solo te tira el resultado como lo hiciste en el video,
    =SI(F6<2;"DEFICIENTE";SI(F6<3;"INSUFICIENTE";SI(F6<4;"ACEPTABLE";SI(F6<5;"SOBRESALIENTE";SI(F6=5;"EXCELENTE";"ERROR")))))

    intente hacer otros ejercicios y no me salían, pero encontre este error, en realidad no sé si es error. GRACIAS

  19. Estimado muchas gracias por tus lecciones. Me sirven de mucho.
    Por favor con respecto a la tarea no me sale. Podrías indicarme cual seria la formula correcta.

  20. GRACIAS DOSTIN POR OTORGAR ESTE MATERIAL Y TENER LA PACIENCIA PARA PODER EXPLICAR TODO DE LA MANERA MAS SIMPLE.

    TENGO UNA DUDA, QUE FUNCION PUEDO OCUPAR Y COMO OCUPAR DICHA FUNCION EN CASO DE QUE EXISTA, PARA PODER PONER UNA CONDICION DE CAMBIO DE COLOR DE UNA CELDA Y ESTA VALLA CAMBIANDO, SI EL TEXTO CAMBIA.

    DE ANTE MANO MUCHAS GRACIAS, Y ESTARÉ ATENTO A TU RESPUESTA.

Deje una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *