5 Comentarios


  1. roberth

    Saludos desde Venezuela Dostin, primero te doy las gracias porque a través de ti he aprendido mucho sobre el diseño web y php eres un excelente profesor. Pero tengo una duda con respecto al login. El login me funciona perfectamente de manera local (localhost). Pero al subirlo en el hosting, no me funciona, el login pasa desapercibido el filtro por usuario y contraseña y accesa a la pagina que quiero bloquear . Pero como dije antes, de manera local si funciona bien. que estaré haciendo mal. espero tu ayuda y pronta respuesta por favor. Gracias.

    1. Dostin Hurtado

      Hola Roberth!
      Verifica la conexión a la base de datos, puede que ahí este el error ya que es lo único que cambia al subirlo a un hosting.
      También en el archivo «abrir_conexion.php» borra la linea que dice «error_reporting(0);» para que la pagina muestre errores en caso de que hallan.
      Saludos!

  2. David

    Hola Dostin! Saludos desde España.

    Lo primero agradecer tu proyecto «El conocimiento es para todos». Eres un excelente comunicador y me alegro mucho de participar de tus lecciones.

    Me ocurre el siguiente error:

    Warning: mysqli::__construct(): (HY000/1045): Access denied for user ‘dostin’@’localhost’ (using password: YES) in C:\xampp\htdocs\programacion\cap9\abrir_conexion.php on line 15
    Nuestro sitio experimenta fallos….

    Por muchas vueltas que le doy, sólo se me ocurre que la contraseña de MySql sea incorrecta. He importado la base de datos que das como material de apoyo y he seguido tus sabias lecciones.

    ¿Me puedes ayudar?

  3. David

    Ya he visto el siguiente vídeo y he encontrado cuál era el problema. He importado la base de datos propietario.sql, he cambiado en abrir_conexion.php el usuario y la clave de la siguiente manera: $usuariodb = «root»; $clavedb = «»;

    Todo solucionado.

    Gracias Dostin

  4. Ernesto

    Hermano Dios te Bendiga, Gracias por compartir, se nota tu alegría al enseñar, eres exceente Profesor y persona. Hasta el momento mi duda esta en el CRUD, en cuanto a la consulta, tengo todo como tu, y el registro no existe, y no entra en esa parte, para indicar que no existe. Que será?. Gracias.
    Vi muchos videos en youtube y te encontre a ti, y que facil entenderte. Desde Venezuela un abrazo.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *